Update: Stay AI is no longer experiencing issues with Analytics, MCP, Staylien, and Exports. We are continuing to monitor as Snowflake has not yet confirmed full resolution of the underlying incident.
Posted Aug 03, 2026 - 17:37 UTC
Monitoring
Update: Stay AI is no longer experiencing issues with Analytics, MCP, Staylien, and Exports. We are continuing to monitor as Snowflake has not yet confirmed full resolution of the underlying incident.
Posted Aug 03, 2026 - 17:37 UTC
Investigating
Stay AI Analytics, MCP, Staylien, and Exports are currently unavailable due to a Snowflake service outage. We are monitoring Snowflake's status and will update this page as the situation changes. https://status.snowflake.com/