Customer Portal Outage

Incident Report for Stay Ai Status

Resolved

This incident has been resolved.
Posted Jun 08, 2026 - 15:30 UTC

Investigating

We are investigating an outage that is impacting the customer portal that started at 10:56am EST. We are working to resolve this issue.
Posted Jun 08, 2026 - 15:25 UTC
This incident affected: Customer Portal.